Keine Netzwerkverbindung nach Profil Switch / Fehlerberichte / NetSetMan Support

NetSetMan Support

Search for already answered questions about NetSetMan (Pro) or ask new ones

You are not logged in.

#1 2017-11-14 11:07

msirlp
Member
Registered: 2017-11-14
Posts: 1

Keine Netzwerkverbindung nach Profil Switch

Hallo,

nach dem Wechsel/Aktivierung zum/des Arbeitsplatz Profils bringt NSM eine Fehlermeldung bei Geschwindigkeit & Duplex und der Domäne. Log Datei ist vorhanden wollte ich aber nicht öffentlichen posten.

Wechsel ich im Anschluss auf das Private Home (HomeOffice) Profil und danach wieder zurück, so findet der Adapter schon im Windows nicht mehr das Domänennetzwerk.
Er schreibt lediglich "Nicht identifiziertes Netzwerk", wobei das vor der NSM Installation aber noch ging.

Abhilfe schaffte auch kein de- bzw. aktivieren des Adapters sondern nur die Neuinstallation des Geräts.


Ich habe auch die Vermutung, dass Gewisse Einträge in der settings.ini nicht mit den Werten der Netzwerkadapter übereinstimmen. Zb. NICID oder NICMAC. Zumindest wenn ich mir die Ergebnisse aus dem Geräte-Manager und ipconfig /all anzeigen lasse.

Woher nimmt er denn die in der settings.ini AdapterID im Profilabschnitt bzw. folgende Informationen:

[Device0]
NICLabel=LAN-Verbindung
NICName=Intel(R) 82579LM Gigabit Network Connection
NICID={57CB7EF3-7712-4708-A276-DB339AB8E657}
NICMAC=9C:B6:54:9E:1D:48

Gut Name und MAC ist klar, aber die anderen?

Als Version von NetSetMan Pro ist 4.5.1 installiert.
Im Einsatz befindet sich Windows 7 Enterprise x64. NSM Dienst ist nicht installiert.


Grüße

Offline

#2 2017-11-14 12:07

NetSetMan Support
Administrator
Registered: 2005-08-06
Posts: 1,841

Re: Keine Netzwerkverbindung nach Profil Switch

Senden Sie uns bitte den erwähnten Aktivierungslog, der zur Aktivierung gehört, mit der das Problem begonnen hat, per Email an die auf der Kontaktseite angegebene Email-Adresse zu. Fügen Sie der Email einen Link zu dieser Forumsseite hinzu, um darauf zu verweisen. Wir prüfen anschließend, wie die Fehler lauten.

msirlp wrote:

Abhilfe schaffte auch kein de- bzw. aktivieren des Adapters sondern nur die Neuinstallation des Geräts.

Ist mit "Gerät" der Netzwerkadapter oder das Laptop gemeint?

msirlp wrote:

Woher nimmt er denn die in der settings.ini AdapterID im Profilabschnitt bzw. folgende Informationen: [...]

Die Informationen werden beim Aktualisieren der Netzwerkadapterliste ausgelesen, gespeichert und können ab dann den Profilen zugeordnet werden.
Wenn die dort aufgeführten Werte falsch wären (insbesondere NICID), würde der Netzwerkadapter bei der Profilaktivierung im System nicht gefunden werden und die Aktivierung würde grundsätzlich fehlschlagen, ohne dass sich am System etwas verändert.
Wenn Sie dennoch den Verdacht haben, dass hier etwas nicht passt, führen wir gerne auch an diesem Punkt eine Analyse durch. Senden Sie uns hierzu ebenfalls per Email folgende Daten zu:
1. settings.ini aus dem Programmverzeichnis
2. Ausgabe von ipconfig /all
3. Öffnen Sie in NetSetMan: Tools > Adapter Details und exportieren Sie die die Liste als Text-Datei.

msirlp wrote:

NSM Dienst ist nicht installiert.

Bedeutet dies, dass Sie beim Programmstart die UAC-Meldung manuell bestätigen oder ist die Benutzerkontensteuerung bei Ihnen komplett deaktiviert? Ob dieser Dienst installiert ist, sehen Sie entweder in den Programmeinstellungen oder in der services.msc-Anzeige.

Offline

#3 2017-12-08 10:55

Billyboy
Member
Registered: 2016-09-22
Posts: 8

Re: Keine Netzwerkverbindung nach Profil Switch

Ich habe das gleiche Problem, allerdings mit der Version 4.60 (zumindest ist es mir erst jetzt aufgefallen).  Profilswitch hat mehrfach nicht funktioniert, wurden falsche Einstellungen geladen. Nach einem reboot wurden dann die richtigen settings geladen, allerdings wieder nur bis zum Profilswitch. Nach einem Absturz des NSM war die komplette Konfiguration & Profile weg.
Habe jetzt den NSM deaktiviert.

Offline

#4 2017-12-08 11:10

NetSetMan Support
Administrator
Registered: 2005-08-06
Posts: 1,841

Re: Keine Netzwerkverbindung nach Profil Switch

Das Problem von msirlp wurde bereits analysiert und gelöst. Es lag in dem Fall daran, dass im Profil die MAC-Adresse geändert werden sollte und da das gleiche Profil auf mehreren Systemen aktiviert wurde, hatten anschließend mehrere Systeme dieselbe MAC-Adresse. Dies führt aus netzwerktechnischer Sicht zu Kollisionen im Netzwerk, sodass Rechner mit der gleichen MAC-Adresse keine funktionierende Netzwerkverbindung haben.

Ihr Problem scheint ein anderes zu sein.
Wir haben in Version 4.6.0 keinerlei Änderungen an den IP-Funktionalitäten gemacht. Wenn Sie zuvor mit einer älteren Version keine Probleme hatten, so wird die Ursache für das aktuelle Problem ggf. wo anders zu suchen sein.
Um ein solches Problem zu analysieren, sind wir auf genauere Details angewiesen. Nur mit "Profilswitch hat mehrfach nicht funktioniert, wurden falsche Einstellungen geladen." haben wir leider keinen konkreten Ansatzpunkt. Was bedeutet genau "hat nicht funktioniert"? Welche falschen Einstellungen wurden stattdessen geladen? Wenn das Problem reproduzierbar ist, senden Sie uns bitte den Aktivierungslog eines Profils, dessen Einstellungen nicht korrekt gesetzt wurden. Zusätzlich bitte die settings.ini aus dem Programmverzeichnis und die Ausgabe von "ipconfig /all" (entweder aus cmd.exe oder aus den NSM Tools > Kommandozeile). Dann können wir sehen, was aktiviert werden sollte, was aktiviert wurde und was das faktische Ergebnis war, sodass wir ein Fehlerbild ableiten können.

Das Problem mit dem Absturz und den verlorenen Einstellungen ist vermutlich ein anderes und sollte gesondert betrachtet werden. Beschreiben Sie bitte dennoch kurz, wie bzw. bei welcher Aktion das Programm abgestürzt ist.

Offline